Tests being aborted by system
Incident Report for k6
Resolved
We have implemented a retry mechanism to mitigate the temporary unavailability of the AWS Elastic Cache service. The intermittent connection problems with AWS Elastic Cache should no longer impact k6-cloud.
Posted Nov 26, 2021 - 19:23 CET
Update
The service is available and working.
This morning we have had two interruptions. At 8:27 UTC and 10:23 UTC. In each case, running tests were aborted, and service was unavailable for 4 minutes. Since 10:28 UTC, the service has been stable (5 hours).
The incident was caused by temporary unavailability of AWS Elastic Cache.
We keep this incident open while we are monitoring the infrastructure and implementing a mitigation strategy for similar interruptions.
Posted Nov 25, 2021 - 16:41 CET
Monitoring
A fix has been implemented and we are monitoring the progress.
Posted Nov 25, 2021 - 13:58 CET
Investigating
We are currently investigating an issue that is causing a portion of k6 Cloud test runs to be aborted (by system)
Posted Nov 25, 2021 - 09:50 CET
This incident affected: Test Runners ("k6 cloud script.js" remote execution mode) and api.k6.io Cloud REST API.